Start a new topic

Possible Issue: The Ungrouped Group with One Item

Okay, here's one for the bug tracker:

I was just experimenting with a few shapes. One of them was a shape from the EasyShape tool, converted to paths and modified only slightly. The shape was neither in a group nor itself a group. But when I tried to delete it, I got this:


To the right is the shape I had selected. When I pressed delete, I got the dialog on the left. And the object I tried to delete remains resolutely undeleted.

I just tried repeating it, successfully. I can't tell if it's doing something wrong or I am.

Steps to replicate:

  1. Create a new Canvas document; portrait-format illustration will work fine for this.
  2. Select the EasyShape tool (on the Rectangle sub-palette) and diamond (shape #2 on the sub-sub-palette), then draw one in the document space.
  3. Select the shape you just drew.
  4. Select the menu item Path | Convert to Paths. When you do that, the selected shape will register as a group. I could see this because in the toolbar at the top of the window, the Ungroup button ungrays and becomes available.
  5. Select the direct group selection tool from the selection sub-palette.
  6. Double-click the shape you drew. The shape will enter point edit mode.
  7. Drag some of the points around. In my example I band-selected the center two points and shift-dragged them downward. Interestingly, I failed to replicate it when I shift-clicked and accidentally deleted a point.
  8. Double-click outside the editing area to close point edit mode on the shape. 
  9. Select the now modified shape again. Note that the Ungroup button in the toolbar is still greyed out—the object doesn't register as a group.

Now, something's going on here, but I have no idea what.

 I managed to duplicate what you describe.  I could avoid the problem by not using the group selection tool.  Using the normal selection tool allowed me to select the group, ungroup (command-u), and then treat the two objects separately.  One part of the group after ungrouping is the polygon, the other is a bezier curve (the same as the polygon) without any fill and without any line thickness.


Hello David,

I understand Tim Anderson was able to replicate the same issue you are having, however following your exact steps I was not able to get the EasyShape object to be converted to a group after choosing Convert to Paths.

At least not with the second EasyShape in the palette. The only time you should get a group is if you convert an EasyShape consisting of multiple shapes into a Path.

As for groups, yes if you try to delete one of two objects within a group Canvas will complain and not allow you as a group consists of more than one object. This only happens if you use the direct group selection tool. Using the regular selection tool will just select the entire group.

What version of Canvas are you using? Just want to know why you are getting a group of two objects for an EasyShape consisting of just one object.



I thought I was using the current version 5.0.1 build 37, according to the About box.

However, I just failed to reproduce the problem. And mind you, I only use one computer, so the instructions I wrote above were transcribed as I performed each step.

Come to think of it, there was an OS update recently. 10.14.1 dropped in the past month, and I'm now wondering if a change well under the hood affected something on the application layer.

Not on that level, meaning it would not change how we convert objects to path. Again the message you got from trying to delete an object within the group with the direct group select is normal. My thing is, how were you able to get a group from a single object EasyShape.

Thanks for your response

Then I'm not sure what to tell you, Albert — I recorded it line by line as it happened before, it's not happening now, and the only variable I could think of changing between then and now is the OS update. For whatever reason, it doesn't appear to be the problem it used to be. (That still bothers me, but it means there's nothing to work around, so that's nice.)

Login or Signup to post a comment